I get asked this all the time.  Visual Studio 2005 has many new features that would be helpful for customers who are still targetting the .NET Framework 1.1.  However, Visual Studio 2005 only targets the .NET Framework 2.0.  John Rivard explains why here.  I came across this blog by way of Somasegar's Blog.

The VB Team just wrote about John's blog entry as well.  "[W]e’re going to be seriously tackling the cross-targeting problem."  They are looking for feedback on your requirements for cross-targeting.  If you have feedback, please provide it here.

-Marc