Every once in a while, we see failures from customers trying to deploy VS 2005 due to incorrect operating systems.

The .NET Framework is supported from Windows 98 and up. 

Visual Studio itself requires Windows 2000 SP4 and up.  Here's the list of supported operating systems for VS:

  • Windows 2000 SP4
  • Windows XP SP2
  • Windows 2003 SP1

These are the minimum requirements so if a newer service pack is available, you'll be fine.

Longhorn is also supported.  Currently Longhorn contains the Beta 2 framework so you can only install VS 2005 Beta 2 on Longhorn.