The build process in the developer division builds symbols for all our binaries on a daily basis.  Once we ship, we have a process that publishes those symbols to the online Microsoft Symbol Server to enable developers to debug into parts of Visual Studio.

After we shipped VS 2008 SP1, the publishing process happened and the symbols were pushed to the external symbol server.  However, it looked like we had so much data on the symbol server that the process failed in the middle and some symbols didn't get pushed.  We didn't realize this until a couple of weeks ago, a VSIP partner emailed me and was wondering why they weren't able to debug into a core VS file - MSEnv.  It turned out the msenv.pdb symbol was missing.

It took a few hours for us to track this down and we finally found the error in the publishing logs.  It took another few hours for the folks who run the Symbol Server to determine it was a disk space issue and then open it up for us to republish the symbols.

All that happened last week and we should be back up and running.  If you've been running into debugging problems because msenv.pdb was missing, try again as things should be working now.

<UPDATE> Some partners have mentioned they're still having problems getting the symbols for msenv.dll.  If you run into this, the work around is to automatically download all pdbs from the Code Center Premium site.  This is different from the VS 2008 RTM instructions which asked you to download the PDBs manually.  Once you have VS 2008 SP1 installed, we recommend you to download all the pdbs automatically.  You can achieve this by unchecking the option under Tools->Options->Debugging->Symbols.