Remote Desktop Connection (Terminal Services Client 6.1) for Windows XP SP2 x86 platforms

Remote Desktop Connection (Terminal Services Client 6.1) for Windows XP SP2 x86 platforms

  • Comments 99

Hello everyone,

we heard a lot of feedback from you about the need for the Remote Desktop Connection client 6.1 to be made available as a standalone install for Windows XP SP2 to ease deployments of Windows 2008 Terminal Services.

In response to this feedback, we have released the Remote Desktop Connection client (RDC 6.1) for Windows XP SP2 on x86 platforms.

You can download RDC6.1 for Windows XP SP2 from the Microsoft Download Center (KB 952155) for the following languages:

Arabic, Chinese - Simplified, Chinese – Traditional, Danish, Dutch, English, Finnish, French, German, Greek, Hebrew, Hungarian, Italian, Japanese, Korean, Norwegian, Polish, Portuguese – Portugal, Portuguese – Brazil, Russian, Spanish – Spain, Swedish, Turkish.

We have also released the MUI package for RDC6.1 on Windows XP SP2 from the Microsoft Download Center (KB 952230).

These are some of the supported features of Remote Desktop Client 6.1 for Windows XP SP2:

  • Windows Server 2008 & Windows Vista feature support
  • TS Web Access support
  • TS Easy Print support
  • TS Remote Programs support
  • TS Gateway support

Please review the complete list of features and details about RDC6.1 for Windows XP SP2 in this Knowledge Base article.

 

 RDC6.1 is now available on the following platforms:

 

Windows Server 2008

Windows Vista SP1

Windows XP SP3

Windows XP SP2 (KB 952155)

Leave a Comment
  • Please add 5 and 1 and type the answer here:
  • Post
  • PingBack from http://smokingun.wordpress.com/2008/06/26/rdc-61-client-for-windows-xp-sp2/

  • Do this update will be available on Windows Update/WSUS ?

  • PingBack from http://www.ipmer.com/2008/06/rdp-client-61-for-xp-sp2.html

  • Reply for Zomby :

    No, this update is only avialable on the Download Center. It is not avialbale via WU.

  • Hi. I downloaded this because the previous 6.0 RDP client stopped saving credentials within the RDP files themselves. As a result, automatic logins to different servers on different ports within the same domain using different credentials are broken because MSTSC uses the last cached credentials. I don't want to have to reconfig hosts files to fake domains just to enable auto login. Is it possible with this release to set up separate user/pass combinations for autologin to different hosts/ports within the same domain?

  • Only for XP SP2? What about SP3? Can't find any download for SP3. The link redirects to a page for the SP3 overview...

  • Reply for Vandrey:

    XP SP3 contains RDC6.1. You can download XP SP3 here : http://technet.microsoft.com/en-us/windows/bb794714.aspx

  • For the last year or so, I have been using my Laptop to allow me to connect to my server hosted in VM

  • Hi, My XP is now SP3, but the RDC crashes when it is trying to connect. It worked fine a couple weeks ago (with SP3). I've tried connecting to 2 different computers. In the error signature it says AppName:mstsc.exe AppVer:6.0.6001.18000 ModName:mstscax.dll

    Stuck on what I can do to fix it, any help is appreciated. If I need to get help elsewhere, please suggest. Thanks.

  • What about Windows 2003 x64? or Windows XP x64?

  • Looks like Microsoft listened. The RDC v6.1 is required for clients to work with TS Web Access. Originally, Microsoft only made this update available through the XP SP3 upgrade. But enough people balked that they announced a standalone download back on

  • How do we get a RDC 6.1 package for Server 2003?

  • I opened a support case with Microsoft today re: Windows XP x64 and Windows 2003 x64 clients with no futher information.  However, I did get a chance to waste an hour and thirty minutes of my time waiting on the phone.

  • I'm wondering. Will the TSC 6.1 be the latest version for Windows?

  • Thanks for this, as it will make my TS2008 deploy go even smoother than it has been already.  One question though:  Using this update to XPSP2 clients, is .NET Framework 3.0 SP1 still required for Easy Print?

    Previously, it was my understanding that XPSP3 and .NET Framework 3.0 SP1 were required.

Page 1 of 7 (99 items) 12345»