It's already bothering me many times when I am export my Hyper-V VM (with important snapshots) and trying to import to another machine and hit this error without further information:

Failed to import the virtual machine from import directory 'C:\vpc\somevpc1\'. Error: One or more arguments are invalid(0x80070057)

been searching on the internet and not found very useful information until today. this saving me lots of time to locate the problems via copying super large VM (>50GB) around my networks.

found the post from John Rennie in this technet forum: http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/5b731f1a-f495-4d88-a875-0eea77ecd6b4

(for my reference, leave a copy of info here.)

In http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/85dc7d36-491f-4b02-88ac-63c1ed0d94db I described a problem when exporting from a Hyper-V server and trying to import into a different Hyper-V server in a different domain. The import failed and the event log contained:

Failed to import the virtual machine from import directory 'D:\HV\Test\Test4GB-3\'. Error: One or more arguments are invalid(0x80070057)

Well I've now identified the source of the problem. In the .exp file is:
<INSTANCE
  CLASSNAME="Msvm_VirtualSystemGlobalSettingData">
...
  <PROPERTY NAME="ScopeOfResidence" TYPE="string">
    <VALUE>
      e7668fbc-216e-4ed1-8ce3-3b932b42e22b
    </VALUE>
  </PROPERTY>
If I edit the .exp file and delete the <value>..</value> then the virtual machine imports with no errors.

you should find the master exp file under the exported VM under VirtualMachine folder. open the file and locate the Msvm_VirtualSystemGlobalSettingData instance, should be in the top of the file, locate the ScopeOfResidence property and just clear that GUID (leave the <value> tag there). import the modified VM again and you will success.

Thanks John for sharing the info, and FYI.