Med hjälp av Multi-targeting funktionaliteten i Visual Studio 2008 kan du öppna ASP.NET 2.0-projekt som innehåller ASP.NET AJAX 1.0-funktionalitet och fortsätta arbeta med dem utan problem.

Däremot kan du inte skapa ett ASP.NET AJAX 1.0-projekt från start i Visual Studio 2008. Skapar du ett nytt AJAX-projekt med den projektmall som leveras med VS 2008 så får du ett ASP.NET AJAX 3.5-projekt, som har referenser till 3.5-versioner av de assemblies som används och som har motsvarande inställningar i web.config.

För att åtgärda det kan du gå in manuellt och ändra referenser och web.config - men nu finns det även en Visual Studio-mall tillgänglig för dig som behöver fortsätta arbeta med ASP.NET AJAX 1.0. Med den kan du använda AJAX 1.0 Enabled ASP.NET 2.0 Web sajt eller application när du skapar ett nytt projekt:

ajax1mall

För att kunna använda den krävs att ASP.NET AJAX version 1.0 finns installerad.