.NET 3.5 and SQL 2008 NOT SUPPORTED for WSS 2.0 and SPS2003

.NET 3.5 and SQL 2008 NOT SUPPORTED for WSS 2.0 and SPS2003

Rate This
  • Comments 2

The .NET 3.5 Framework (RTM and SP1) are not supported for use on WSS 2.0 and SPS2003 platforms. (This includes installing Visual Studio 2008, as it installs .NET 3.5) It is going to cause webparts to error.

Symptoms

If .NET Framework 3.5 SP 1 is installed on WSS v2 the symptoms are:

 

Each web part will display the following error:

 

Web Part Error: A Web Part or Web Form Control on this Web Part Page cannot be displayed or imported because it is not registered on this site as safe.

 

Also, the following NT Events are reported:

 

NT Event Viewer Application Log displays multiple error warnings:

Event ID: 1000

Error initializing Safe control - Assembly: Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c TypeName: * Namespace: Microsoft.SharePoint.SoapServer Error: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

 

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

 

Workaround:

Workaround:  Uninstall In Add/Remove Programs remove Microsoft .NET Framework 3.5 SP 1 and Microsoft .NET Framework 3.0 and uninstall Microsoft .NET Framework 2.0.  Then reinstall .NET Framework 2.0 Service Pack 1 http://www.microsoft.com/downloads/details.aspx?FamilyID=79bc3b77-e02c-4ad3-aacf-a7633f706ba5&DisplayLang=en.



Also, SQL 2008 is not supported for the WSS 2.0/SPS2003 platform. There are currently not any known issues, but there are no plans to support the combination of products.

Leave a Comment
  • Please add 2 and 5 and type the answer here:
  • Post
Page 1 of 1 (2 items)