SAP Support for SQL Server 2012 - Update

SAP Support for SQL Server 2012 - Update

  • Comments 1

SAP supports SQL Server 2012 for most SAP NetWeaver based products for quite a while – read my earlier blog post for more information. However, SAP now also supports products which are based on SAP NetWeaver 7.1, SAP EHP1 for SAP NetWeaver 7.1 (7.11), SAP NetWeaver Composition Environment 7.1 (CE 7.10), SAP NetWeaver Composition Environment 7.1 Including Enhancement Package 1 (CE 7.11) and SAP NetWeaver Composition Environment 7.2 (CE 7.20)

The following products are based on those releases:

  • SAP NetWeaver Mobile 7.1
  • SAP EHP1 for SAP NW Mobile 7.1
  • SAP NetWeaver PI 7.1
  • SAP EHP1 for SAP NW PI 7.1
  • SAP NetWeaver CE 7.1
  • SAP EHP1 for SAP NW CE 7.1
  • SAP NetWeaver CE 7.2

You have to use Software Provisioning Manager (SWPM) to install these products. For more information, please read SAP Software Provisioning Manager (SWPM).

Please also read the following SAP notes for more Information about how to install or upgrade for SAP System to SQL Server 2012:

SAP Note 1676665  - Setting up Microsoft SQL Server 2012 (Login required)
This SAP note describes how to install, upgrade SAP Systems on SQL 2012 and how to perform System copies on SQL 2012

SAP Note 1684545 - SAP Installation Media and SQL4SAP for SQL Server 2012 (Login required)
This SAP note lists the available SQL Server 2012 RDBMS DVDs

SAP Note 1702408 - Configuration Parameters for SQL Server 2012 (Login required)
This SAP note describes how you can configure SQL Server 2012 and lists the required configuration for a SQL Server 2012 that is running a SAP System.

Please always read the PAM on https://service.sap.com/pam to check if your product is supported on the platform you are using.

How-To: Installation

SAP Notes

  • 1680045 - Release Note for Software Provisioning Manager 1.0 (Login required)

Requirements

  1. Windows Server 2008 SP2 64-bit or Windows Server 2008 R2 SP1 64-bit
  2. ABAP/APAB+JAVA: SAP Solution Manager
  3. SQL Server 2012 Enterprise (Core) Edition
  4. SAP UC-Kernel 7.20 EXT DVD as described in SAP Note 1680045 (Login required)

Preparation

  • SQL Server Native Client 2012
    • If you want to install a distributed SAP System (database and SAP application Server are running on different hosts), make sure that the SQL Server Native Client 2012 is installed on the host running your SAP application Server

Installation

  • Install your SAP system using
    • The SAP Software Provisioning Manager (SWPM)
    • The Kernel DVD as described in SAP Note 1680045 (Login required)
    • The DVDs that were originally shipped with the product that you want to install (Export DVD, Java DVD, language DVDs…)
  • After the Installation upgrade your kernel to the latest 7.20 EXT Kernel
  • ABAP/ABAP+JAVA: Connect your new SAP System to your SAP Solution Manager
  • ABAP/ABAP+JAVA: Create a maintenance stack to implement at least
    • SAP NetWeaver Mobile 7.1 SPS 14
    • SAP EHP1 for SAP NW Mobile 7.1 SPS 10
    • SAP NetWeaver PI 7.1 SPS 14
    • SAP EHP1 for SAP NW PI 7.1 SPS 10
  • ABAP/ABAP+JAVA: Use the Software Update Manager (SUM) 1.0 SP7 or higher to implement the maintenance stack
    • DO NOT use SPAM to implement the support packages
    • DO NOT update SPAM manually but let the SUM update the SPAM as part of the maintenance stack implementation

Post Steps

System Copy

You can also copy your SAP System that is running on an older SQL Server to a machine running a new SQL Server with the following steps:

  • ABAP/ABAP+JAVA: Make sure that your source system is at least on
    • SAP BASIS 7.10 SP 14 for  SAP NetWeaver Mobile 7.1 or SAP NetWeaver PI 7.1
    • SAP BASIS 7.11 SP 10 for SAP EHP1 for SAP NW Mobile 7.1 or SAP EHP1 for SAP NW PI 7.1
  • Copy your SAP system using
    • The SAP Software Provisioning Manager (SWPM)
    • The Kernel DVD as described in SAP Note 1680045 (Login required)
    • The DVDs that were originally shipped with the product that you want to install (Export DVD, Java DVD, language DVDs…)

The steps for a System Copy where the source SAP system is already running on SQL 2012 are the same.

How-To: Upgrade/Update

Upgrade to products that are based on SAP NetWeaver 7.1

Upgrades to SAP NetWeaver 7.1 are not supported on SQL Server 2012. Please upgrade your product to a SAP NetWeaver 7.3 or higher based product e.g. for SAP NetWeaver PI 7.1 please upgrade to SAP NetWeaver PI 7.3 or higher.

Upgrade to SAP NetWeaver CE 7.1

There is no upgrade path to SAP NetWeaver CE 7.1.

Upgrade to products that are based on SAP EHP1 for SAP NetWeaver 7.1 (7.11)

Upgrades to SAP EHP1 for SAP NetWeaver 7.1 are not supported on SQL Server 2012. Please upgrade your product to a SAP NetWeaver 7.3 or higher based product e.g. for SAP EHP1 for SAP NetWeaver PI 7.1 please upgrade to SAP NetWeaver PI 7.3 or higher.

Update to products that are based on SAP EHP1 for SAP NetWeaver 7.1 (7.11) or SAP NetWeaver CE 7.2

Source releases

    • SAP NetWeaver Mobile 7.1
    • SAP NetWeaver PI 7.1
    • SAP NetWeaver CE 7.1
    • SAP EHP1 for SAP NetWeaver CE 7.1 (CE 7.11)

SAP Notes

Requirements

    • Make sure that the Kernel archive that is contained in the stack meets the patch level requirements that are described in SAP Note 1676665 (Login required). It is recommended to use a SAP Kernel 7.20 EXT.
    • Use SAP Software Update Manager (SUM) 1.0 SP7 or higher

Update to higher SAP releases

Source releases

    • SAP NetWeaver Mobile 7.1
    • SAP EHP1 for SAP NW Mobile 7.1
    • SAP NetWeaver PI 7.1
    • SAP EHP1 for SAP NW PI 7.1
    • SAP NetWeaver CE 7.1
    • SAP EHP1 for SAP NW CE 7.1
    • SAP NetWeaver CE 7.2

Target Releases

    • SAP EHP1 for SAP NetWeaver Mobile 7.3
    • SAP NetWeaver PI 7.3
    • SAP EHP1 for SAP NetWeaver 7.3
    • SAP NetWeaver 7.3
    • SAP EHP 1 for SAP NetWeaver 7.3

SAP Notes

Requirements

    • Make sure that the Kernel archive that is contained in the stack meets the patch level requirements that are described in SAP Note 1676665 (Login required). It is recommended to use a SAP Kernel 7.20 EXT.
    • Use SAP Software Update Manager (SUM) 1.0 SP7 or higher
Leave a Comment
  • Please add 6 and 8 and type the answer here:
  • Post
  • Please also update regarding SAP BO Support on windows 2012

Page 1 of 1 (1 items)