Installed Windows XP SP2? Installed the .NET FW 1.1 SP1? (which if you were install inside Microsoft came as part of Windows XP SP2 install, but externally it will be a separate download available shortly.)

If you did install the .NET FW 1.1 SP1 then you need a hotfix to the rules engine component that resolves a breaking change made in the Framework(for a good reason that only effects the rules engine - all your user code will work fine) that stops the rules engine working.

The KB article you need is 875540 [FIX: You receive a "Specified cast is not valid" error message in BizTalk Server 2004 when you use a rules set....] and it isn't quite online yet but it will be in a hour or three (I just saw the publish notification go by). Thanks for coming to TechEd Australia, NZ and for the IMPRESSIVE turn-out of customers in Melbourne last Friday. 

I'm officially on holiday and its sunny outside so you know that means I'm inside completing the my book contribution (no it isn't done yet but it will be by Friday as I just have the pictures to go).  

Update: That chapter is now submitted to review.  There is one other chapter MIA I need to hunt and destroy to get this thing done.