I'll keep this simple. If you are currently doing EDI in a significant way it is highly likely you need the Covast EDI Accelerator.  But of course you want to know more details such as what is and isn't technically supports in the base EDI adapter.  You can find out all those details by reading this document.

Thanks to Brian and the folks from Covast for putting this together.