Problem: 

Wenn man auf dem Terminal Server über Citrix App-V Anwendungen zur Verfügung stellt, die gerade aktualisiert wurden, kann es zu folgenden Fehler kommen:

The OSD file you are attempting to use is newer than the one cache, but you do not
have permission to update it. You can launch the application by using the original
OSD file or y specifying its name instead of using an OSD file.
error code: XXXXXX-XXXXXX44-00001005

Sobald man ohne das Citrix "publishing" auf den Server zugreift, funktioniert die Anwendung.

Lösung:

Zum veröffentlichen von App-V Anwendungen sollte die OSD angegeben werden: "SFTTRAY.EXE /HIDE [PFAD zur OSD] anstatt zum Shourtcut zu zeigen.

Zudem sollte der folgende Registry Key gesetzt werden:

"UpdateOSDFile" = 1 anstelle von 0 der Key befindet sich hier:

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Permissions]

Sebastian Gernert - Support Escalation Engineer