In my last post, I talked about the BizTalk AppFabric Connect for Services functionality for BizTalk.  As you start to make your services accessible through the cloud you may find that you hit an error when you try to access the endpoint.  You might also find that your endpoint doesn’t show up in the Windows Azure Portal. 

In my case, I saw this error, in the screen shot below, when I clicked on the URL for my service in the AppFabric portal.

clip_image002

Then I saw that I had the following error in the Event Log.

clip_image002[5]

I knew why the error in the Event Log was showing up.  I have Windows Server AppFabric installed and had configured my service to Auto-Start.  What I didn’t know was why I was getting the underlying error of not being able to reach watchdog.servicebus.windows.net.  After doing a lot of searching on-line I couldn’t find anything that could solve the problem.

So, after talking to a member of the dev team who created the wizard functionality we found a fix.  It turns out you will get this error when the service can not communicate with Azure.  Since I had a proxy server in the mix, the fix was to add an entry in the config file in order for communications to flow through the proxy server.  When the wizard completed it created a set of artifacts in IIS including a config file.  Open that config file and we will add the entry below and place it just before the system.web section.

...
<connectionString />

<system.net>
   <defaultProxy useDefaultCredentials="true">
      <proxy proxyaddress="[your proxy address here]" />
   </defaultProxy>
</system.net>

<system.web>
...

Enter your proxy address and you should see this error go away.