Setup fails when you attempt to install Enterprise Portal If the .NET Business Connector is not installed on the Microsoft Dynamics AX client computer when the initialization checklist is run, then the SysDevelopmentProxy class is not compiled. If this class is not compiled, Setup fails when you attempt to install Enterprise Portal.

 

To compile the SysDevelopmentProxy class, open the AOT > Classes node, right-click SysDevelopmentProxy, and click Compile. If you receive a compile error, then the .NET Business Connector is not installed. Install the .NET Business Connector using Setup, and then compile the AOT (Right-click the AOT root node and click Compile).Once you compile this successfully, then proceed to EP setup.

 

 

Below is the error that you would see in the setup log file. Don't get confused with the last line in the error log as Reason: No .NET Business Connector session could be found. The real issue is the one reported above about SysDevelopmentProxy (object) has no valid runable code in method 'generate' error.

...

...

... 

Deploying proxies...
In SysEPDeployment::deployProxies...
In SysEPDeployment::clrGetVirtualServerProxyDir...
 
Entering function GetConfigurationFilePath
 Leaving function GetConfigurationFilePath
 
 C:\Inetpub\wwwroot\wss\VirtualDirectories\<portnumber>\App_Code\Proxies
In SysEPDeployment::clrGenerateProxies...
 Error executing code: SysDevelopmentProxy (object) has no valid runable code in method 'generate'.

 

(C)\Classes\SysDevelopmentProxy\generate
(C)\Classes\SysEPDeployment\clrGenerateProxies - line 7
(C)\Classes\SysEPDeployment\deployProxies
(C)\Classes\SysEPDeployment\deployAllWebParts
(C)\Classes\SysEPDeployment\deployEPOnSharepoint
(C)\Classes\SysEPDeployment\installEnterprisePortal


Microsoft.Dynamics.BusinessConnectorNet.BusinessConnectorException
   at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object[] paramList)
    at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object param1)
    at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName, Object param1)

An error occurred during setup of Role Centers and Enterprise Portal.
Reason: No .NET Business Connector session could be found.
=== Rolling back setup of Role Centers and Enterprise Portal due to error ===
Launching MSI:  /i "D:\Msi\Components32\Components32.msi" /qb-! /l*v "C:\Documents and Settings\All Users\Application Data\Microsoft\Dynamics AX\Dynamics AX Setup Logs\<Date Time>\Components32 Rollback Log.txt" DIRECTEXECUTE=1 SETUPLANGUAGE=EN INSTALLDIR="C:\Microsoft Dynamics AX\50" INSTALLDIR32="C:\Microsoft Dynamics AX\50" ADDLOCAL="ClientUI,EnterprisePortal,NetBusinessConnector,ClientConfig" REMOVE="EnterprisePortal"
=== Rolling back setup of Role Centers and Enterprise Portal due to error ===
Rollback of === Rolling back setup of Role Centers and Enterprise Portal due to error ===

 installation has been completed. For details about why the installation failed, see the previous messages in the log.


 === Setup was canceled or failed. For details see the previous messages in the log.