SharePoint 2010 Search : not showing any results for anonymous users ?

SharePoint 2010 Search : not showing any results for anonymous users ?

  • Comments 8

I was testing SharePoint search feature in my lab machine and found that once I enable anonymous access on my web application and once I search for keyword it was not displaying any content.

Instead it gives a message:

"We did not find any results for <keyword>"

For the authenticated users, the search results are returned correctly. Later I found that we have to configure a specific setting to show the search results for anonymous users, cause of this issues was due to security trimming.

To get rid of it please do the following.

  • Under the SharePoint Site go to Site Settings.  Search Administration -> Search and offline availability -> Indexing ASPX Page Content, Enable the option "Always index all Web Parts on this site"
  • Under Search Service Application, do a Full Crawl for the content source to resolve this issue.

image

Comments
  • I am having the same problem in my project and the solution which you have provided did not work for us. Is there anytrhing that I am missing or can you please let me know what permissions does the search service account shuld have.

  • I am also facing same problem. After extending site for anonymous user and performed configuration according to this article but still anonymous user is not able to perform search and they are getting blank result.

  • I've tried this solution all throughout my site and re-indexed the site and still anonymous users receive blank results.  This seems more difficult than it should be.

  • Tried your solution and it does not work for me.

    My solution was to disabled to lockdown feature on the site collection, disable anonymous access, then enable anonymous access again, full crawl of the website and it works.

  • This solution did not work for me either.

  • i tried the solution and it is working correctly in case of our story

  • Thanks for posting this,  it resolved our problem.

  • i applied the solution above. and its working perfectly.

Page 1 of 1 (8 items)
Leave a Comment
  • Please add 8 and 4 and type the answer here:
  • Post