Nous avons souvent des questions sur la compatibilité des packs d’administration (management pack) entre les versions de System Center Operations Manager (OpsMgr).

Les packs d’administration d’OpsMgr 2007 sont compatibles sur OpsMgr 2012. A ma connaissance, les rares packs d’administration qui ne l'étaient pas ont été corrigés.

Par contre un pack d’administration développé pour OpsMgr 2012 risque de ne pas pouvoir être importé sur OpsMgr 2007.

Si le pack d’administration est dans le nouveau format .mpb alors vous saurez tout de suite qu'il s'agit d'un pack d’administration pour OpsMgr 2012. Par contre, comment savoir qu'un pack d’administration au format XML n'est que pour OpsMgr 2012 ? Comment l'identifier ?

Il suffit de chercher dans le fichier XML le texte : SchemaVersion="2.0"

clip_image002

Si vous le trouvez c'est qu'il s'agit d'un pack d’administration pour OpsMgr 2012.

Si vous ne retrouvez pas de référence SchemaVersion= c'est qu'il s'agit du schéma 1.0 utilisé par OpsMgr 2007 !

Si vous avez des packs d’administration aux formats .mp et .mpb à convertir en xml, vous pouvez le faire à partir du PowerShell mis à disposition par Daniele Grandini sur :
http://nocentdocent.wordpress.com/2012/02/28/opsmgr-2012-how-to-dump-management-pack-bundles/