Spat's WebLog (Steve Patrick)

When things go wrong...

(OT) Western Digital My Book exprience.

(OT) Western Digital My Book exprience.

  • Comments 10

A few friends have lost data from HD crashes recently - important items like music collections and wedding photos ...  so I thought I should probably begin backing up my items in the interest of self-preservation ( from my wife should I lose all of our pictures from the last 5 years )

I generally ask around and then read plenty of reviews before buying anything - and I settled on the My Book  500 gig version.

Based on everything I had read it works right out of the box. No CD is included, plug it in and go. When I got it, I plugged it in and no go.

Argh.  Maybe it was Vista -- so I plugged it into an XP machine. Arghh. No go.

After much fiddling with connnections, looking in device manager, looking online for drivers etc... I could not figure out why it wasnt working. So, I called WD tech support.

Now, being in the support world is no easy thing to do .... some inbound phone queue with random callers from all over the world with God knows what problem they are mad about and have been on hold for 45 minutes waiting to explode with all of it focused at you ( because you ARE Western Digital to them) .  Well, I'd like to think I am more understanding than that. I dont recall her name - but she asked some basic questions:

  1. Do you see a light on the device? Yes
  2. Is it plugged in a USB  port or direct? Direct
  3. Is it making any noises, grinding etc.? No
  4. When you touch it - is it  humming silently? Yes
  5. Do you see any popups when you plug it in? Yes.. new HW recognized.
  6. Do you see any yellow bangs in device manager? Yes. Unknown Device under system devices.
  7. Do you see any WD devices under Disk Drives in device manager? No.
  8. Is the device plugged directly ( power cord ) into a wall or a power strip? Power Strip.

OK sir, here is what I'd like you to do. Please go to device manager , and uninstall the "unknown device". Done .

OK. Now - turn off the computer and unplug the power  cord from the external drive as well as the USB cable from the computer. Done.  Now, power on the computer.

Here is the kicker... please plug the external drive into a wall plug instead of a power strip. Then, plug the USB cable back into the computer.

Ummm.. can I ask why? Something about power flucuations and such ... it doesnt get enough juice or something to be recognized. Wild.. but OK I do as commanded.

Lo and behold... comes up fine,  recognizes the drive and away we go.

One more thing -- I guess there were a number of bad firewire cables shipped with these, so we will ship you  a new one - just toss the one  you have.

 Great! I couldn't have asked for a better support experience.. kudos to Western Digital's support.

 

spatdsg

 

 

 

 

Leave a Comment
  • Please add 3 and 1 and type the answer here:
  • Post
  • My MyBook is recognized by my XP machine

    but not my Vista Ultimate one. It says

    "Bad USB device".

    Please help.

    rgsemail@gmail.com

    thanks in advance.

  • A million 'thank you's for posting that, spatdsg...  I never would have thought that.  I was having issues with my brand new 320 GB My Book and it worked like a charm.

  • Hey, I agree.  Thanks tremendously for posting that resolution.  It worked like a champ for me....and I thought all of my data was going to be lost forever.....You saved me.

  • I have no idea how this worked with my hard drive running windows vista, but it sure did.  Thanks a bunch.

  • Wow, thought my computer had crashed completely. You saved me!!!

  • You are a legend i was stressing about my 1tb WD mybook and it showing up as an unknown device, downloaded  drivers started lookin for my reciept but my main worry was the data loss, turns out modem and HD have the same power cord :S. thank you very much for posting this useful article.

  • wow... and here I was afraid my drive had died within a week of getting it, and all it required was a wall socket and not a power strip.

    Thanks so much :D

  • I was having issues and searched for "wd mybook unknown device" and your post came up first. This is exactly what my issue what. I plugged it into the wall instead of my strip and everything worked great!

  • I looks like it is not a power strip vis wall power but just the unplugging the drive from the power socket fixes the problem, because that's what I did. Otherwise, the sequence described is important to follow.

    Thanks very much for posting it.

  • Holy Crap.  Really?  I Googled "WD my book uknown devise" and not only did Google correct my spelling but brought up this page and it worked.  I spent hrs working with the drivers pulling my hair out.   Black Magic.

Page 1 of 1 (10 items)