Moved from http://blogs.msdn.com/vijgang
Applies to SharePoint 2007

I had installed Microsoft Office SharePoint Server 2007 (SP2 + Oct CU) on a Windows 2008 Server with IIS 7. I then tried to create a Content Deployment Path on the server.

1. Browse to http://centraladmin-url/_admin/DeploymentPath.aspx

2. Select the "New Path" option.

3. Type the Name and then select the "Source Web Application".

This immediately prompts for a password and none of the accounts work (including local administrator). You end up getting a "Access Denied".

ULS logs show these two errors,

Access Denied for /_admin/DeploymentPath.aspx. StackTrace: Microsoft.SharePoint.Utilities.SPUtility:Void HandleAccessDenied(System.Exception), Microsoft.SharePoint.ApplicationRuntime.SPRequestModule:Void HandleAccessDenied(System.Exception), Microsoft.SharePoint.ApplicationRuntime.BaseApplication:Void Application_Error(System.Web.HttpApplication), Microsoft.SharePoint.ApplicationRuntime.SPRequestModule:Void ErrorAppHandler(System.Object, System.EventArgs), System.EventHandler:Void Invoke(System.Object, System.EventArgs), System.Web.HttpApplication:Void RaiseOnError(), System.Web.HttpApplication+ApplicationStepManager:Void ResumeSteps(System.Exception), System.Web.HttpApplication:System.IAsyncResult System.Web.IHttpAsyncHandler.BeginProcessRequest(System.Web.HttpContext, System.AsyncCallback, System.Object), System.Web.HttpRuntime:Void ProcessRequestInternal(System.Web.HttpWorkerRequest), System.Web.HttpRuntime:Void ProcessRequestNoDemand(System.Web.HttpWorkerRequest), System.Web.Hosting.ISAPIRuntime:Int32 ProcessRequest(IntPtr, Int32),

Application error when access /_admin/DeploymentPath.aspx, Error=Access is denied.

at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_IsContainer()
at System.DirectoryServices.DirectoryEntries.ChildEnumerator..ctor(DirectoryEntry container)
at System.DirectoryServices.DirectoryEntries.GetEnumerator()
at Microsoft.SharePoint.Administration.SPIisApplicationPoolCollection.<GetEnumerator>d__0.MoveNext()
at Microsoft.SharePoint.Administration.SPGlobalAdmin.get_ApplicationPools()
at Microsoft.SharePoint.Publishing.Internal.CodeBehind.DeployPathPage.SetAppPoolRadioButtonLabel()
at Microsoft.SharePoint.Publishing.Internal.CodeBehind.DeployPathPage.OnSourceVirtualServerDropDownChanged(Object sender, EventArgs e)
at System.Web.UI.WebControls.ListControl.OnSelectedIndexChanged(EventArgs e)
at System.Web.UI.Page.RaiseChangedEvents()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Finally managed to find the root cause to be with the permissions of the administrator account. It did not having permissions to access the IIS metabase.

To resolve this,

Start the command prompt
Change to C:\Windows\Microsoft.NET\Framework64\v2.0.50727 (for x64)
Run aspnet_regiis.exe -ga domainname\sharepointserviceaccountname