When installing MS06-061 for MSXML4 SP2, you may receive the following error when trying to run msxml4-KB925672-enu.exe:

 

The specified program requires a newer version of Windows.

 

NOTE - Before installing this update, please make sure you have already installed SP2 for MSXML4.

 

In order to install the update properly, you need to extract the MSI file from the EXE. 

 

To do that, run the following at a command prompt on a Windows 2000 machine or higher:

 

msxml4-KB925672-enu.exe /extract:"c:\temp"

 

This will extract msxml.msi.  You can then install msxml.msi.

 

Posted By: Adam Saxton