Slipstreaming SP1 with SQL Server 2008 Express edition advanced services is not possible

Slipstreaming SP1 with SQL Server 2008 Express edition advanced services is not possible

  • Comments 1

I had a situation where I needed to install SQL Server 2008 Express edition with management studio and also upgrade it to SP1 using just one installer. It does not sound impossible as we already have a similar  installer that can install SQL Server 2005 Express edition with advanced services and also upgrade it to SP3.(http://www.microsoft.com/downloads/details.aspx?FamilyID=B448B0D0-EE79-48F6-B50A-7C4F028C2E3D&displaylang=fr&displaylang=en)

 

We have a similar installer for SP2 aw well. Microsoft SQL Server 2005 Express Edition with Advanced Services Service Pack 2(http://www.microsoft.com/downloads/details.aspx?familyid=5B5528B9-13E1-4DB9-A3FC-82116D598C3D&displaylang=en)

 

The above installers were available once the service packs had become the minimum supported build.

 

As of now we do not have a similar kind of installer for SQL Server 2008 express with advanced services with SP1. Starting with SQL Server 2008, we won’t be shipping new packages of "Express with Advanced Services" or "Express with Tools" with Service Pack 1.

If you have worked on SQL Server 2008 installation, you should have come across the following KB

http://support.microsoft.com/kb/955392

The above article talks about slipstreaming an installation of SQL Server 2008 and also states that

“You should not perform the slipstream procedure to apply SQL Server 2008 Service Pack 1 for the SQL Server 2008 Express edition. SQL Server 2008 Express Edition SP1 is already a merged drop.”

However, I wanted to slipstream “SQL Server 2008 express with advanced services” with “SQL Server 2008 SP1”.

 

This is also not possible as we would get the following error even if the language settings are same between sp1 and sql server 2008 express with advanced services.

---------------------------

Rule Check Result

---------------------------

Rule "Update Setup Media Language Compatibility" failed.

 

The language of the original SQL Server 2008 media and the language of the service pack do not match. To continue, match the language of the service pack with the original SQL Server 2008 media.

---------------------------

OK  

---------------------------

 

Hence slipstreaming will also not help us in installing SQL Server 2008 Express with management studio and with SP1.

 

Solution

To update  the editions "Express with Advanced Services" or "Express with Tools" to SP1, you will need to run the full Service Pack 1 which is available for SQL Server 2008. (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=66ab3dbb-bf3e-4f46-9559-ccc6a4f9dc19)

 

 

Bharath Kumar 
SE, Microsoft SQL Server

 

Reviewed by

 

Rakesh Singh
TL, Microsoft SQL Server

 

 

Leave a Comment
  • Please add 7 and 6 and type the answer here:
  • Post
  • Thanks !!

    Installing the "With Tools" Version solved the problem :)

    Saved my day !!

Page 1 of 1 (1 items)