I wanted to make sure all TFS users adopting 2010 saw this -

This morning TFS released the GDR patch for TFS 2005 users who want to connect to a TFS 2010 server.

http://www.microsoft.com/downloads/details.aspx?FamilyID=22215e4c-af6f-4e2f-96df-20e94d762689

You can find more info about the patch here:

http://blogs.msdn.com/team_foundation/pages/compatibility-update-for-team-foundation-server-2010-rc.aspx

The drive for developing this patch was entirely your user feedback. After long debate, we originally decided to ship only a patch to get a great experience connecting 2008 clients to the TFS 2010 server. However, you guys told us loud and clear you needed 2005 as well. :) Thanks for the feedback. Here is the link to that 2008 compat patch as well, for convenience. :)

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=cf13ea45-d17b-4edc-8e6c-6c5b208ec54d

Thanks!

Steph