Clarifying Sync Framework and SQL Server Compact Compatibility

Clarifying Sync Framework and SQL Server Compact Compatibility

  • Comments 3

http://j.mp/hpmQ4c

Sync Framework and SQL Server Compact install with several versions of Visual Studio and SQL Server, and each version of Sync Framework is compatible with different versions of SQL Server Compact. This can be pretty confusing!

This article on TechNet Wiki clarifies which versions of Sync Framework are installed with Visual Studio and SQL Server, lays out a matrix that shows which versions of SQL Server Compact are compatible with each version of Sync Framework, and walks you through the process of upgrading a SQL Server Compact 3.5 SP1 database to SQL Server Compact 3.5 SP2.

Leave a Comment
  • Please add 5 and 3 and type the answer here:
  • Post
  • Thanks for the post. One question that isn't addressed in the related technet article - what about SQL CE 4?

  • I would also like to know the status on CE4 compability?

  • We need Sync Framework to use it with CE4! Entity Framework 4.1 code-first works only with CE4 and it would be great to use sync with ef4.1 + ce4

Page 1 of 1 (3 items)