I was working with a customer upgrading his TFS 2005 to TFSD 2010; we found an error during the upgrade. The error occurred in the SharePoint configuration screen.

TF250004: The SharePoint Products installation is either corrupt or is not valid. Verify that SharePoint Products is a supported version and is functioning properly, and then try again.


This happened when we click on test on the Sharepoint Url’s during upgrade process.


When we want to use WSS for TFS 2010, The minimum requirement WSS 3.0 with service pack 2 or above


When we installed Service pack 2 for WSS 3.0 the issue was resolved.

Author: Vimal Thiagaraj                                                    Reviewed by Lakhminder