Recently we faced an issue when configuring backups and the error message displayed was misleading. Here is the complete summary of the issue and the solution for the same.

If we have the configured TFS with a named reporting instance that has an underscore (“_”) in its name, you will hit this error when you configure a backup plan for your TFS server with Reporting server databases included. The problem lies with backing of the reporting services encryption key.
For example I am using a reporting instance of the name TFS_Reports. Here is a screen shot of error I see,

and the error stack in the logs would look something like this

+-+-+-+-+-| Verifying Reporting Services encryption key can be backed up |+-+-+-+-+-
Starting Node: ENCRYPTIONKEY
NodePath : Container/Progress/Conditional/ENCRYPTIONKEY
Node returned: Error
Failed to find Reporting WMI namespace for machine tfs13 and instance: TFS_REPORTS

This is a known bug with backup tools. The reason for this is the name of the SSRS name spaces.
The _ is translated to _5f in the name space name (TFS_REPORTS -> RS_TFS_5fREPORTS)

This has been fixed on the Update 2 for TFS 2013. You can upgrade your TFS server to that level. If that’s not possible you can check the work-around below.

The work around for this is to skip reporting databases in the backup plan and to take a backup of those manually. You can follow this article to back up the reporting databases and encryption key.
Or if possible move your reporting instance to one without a _ in its name. You can follow this article if you want to do this.

Content created by Venkata Narasimhan
Content reviewed by Romit Gulati