Recently, I had worked on number of support incident’s where configure new features wizard for upgraded team projects fails with below error.
[Error] TF400654: Unable to configure Planning Tools. The following element contains an error: RequirementBacklog/States. TF400587: This element defines the states for work items that appear on your backlog. Each state must exist in at least one of the work item types belong to category defined in: 'RequirementBacklog/States'. The following state does not exist in any of the work item types: Active, Resolved.

The above error points to missing states in the Workitem types under the “Requirement” category. One would receive these type of issues if they customized the out of the box Workitem types.
Now, how would I know what are all the Workitems were present under “Requirement” category? The easiest way is to refer the categories.xml for the respective team project. First, export the categories.xml for the team project and then refer the Requirement category. Below is the snippet for your reference:

<CATEGORY name="Requirement Category" refname="Microsoft.RequirementCategory">
<DEFAULTWORKITEMTYPE name="Requirement" />
</CATEGORY>

Great, now that I know what the issue is, how do I fix this? The easiest way to resolve this is, to add the missing states “Active” & “Resolved” in the Workitem type “User Story”. But this is not the best way and I don’t want to modify the workflow for the Workitem.
Then how should I do this? What is the best way to resolve this? To answer all these questions, below is the resolution.

First, we should identify from where the error is coming from. Refer the first line of the error message the following element contains an error: RequirementBacklog/States. This error is coming from the processconfiguration.xml. Export the process configuration file and go to the section “RequirementBacklog”. You will find the states

<States>
<State value="Proposed" type="Proposed" />
<State value="Active" type="InProgress" />
<State value="Resolved" type="InProgress" />
<State value="Closed" type="Complete" />
</States>

If you look closely, “Active” & “Resolved” were present under the states but in the “Requirement” work item’s workflow we don’t have these states (assuming the Requirement Workitem was customized). To fix this issue, remove the “Active” & “Resolved” from the <states> and import the processconfiguration.xml.

The states defined under <states> section will be available as swim line columns in the Board. If you want to show the workflow states as swim line columns in the Board, add the states and assign them to Meta states. Once you make the necessary changes import the processconfiguration.xml file to the team project.


Content Created by – Chandra Sekhar Viswanadha