Installing Whidbey Beta 1 and Yukon Beta 2 Together

Installing Whidbey Beta 1 and Yukon Beta 2 Together

  • Comments 5

This is probably blatantly obvious to most people, but I've seen some confusion on this topic over the last couple of days, so documenting it is probably no great disaster. Some people aren't clear about how you install SQL Server 2005 ("Yukon") Beta 2 and Visual Studio 2005 ("Whidbey") Beta 1 on the same machine.

Although Yukon Beta 2 and Whidbey Beta 1 are designed to work together, Yukon shipped about a month later to allow a little longer for bake-testing. The one thing you have to watch out for is that Yukon Beta 2 installs a slightly later version of the .NET Framework (2.0.40607.42, which we'll call Beta 1+ for simplicity) than Whidbey (2.0.40607.16). Visual Studio 2005 can run on either version of the Framework, but SQL Server 2005 depends on the later version as a result of some late bugfixes. So how do you install them together?

If you're starting with a clean machine, the simple answer is to install SQL Server before Visual Studio - that way, the Beta 1+ version of the Framework is already on the machine by the time VS setup runs.

But a lot of people installed VS 2005 as soon as it came out and are perhaps confused by the error message they get from SQL Server when they try to install it. If you find yourself in that situation, uninstall the Beta 1 release of the Framework and then install SQL Server 2005, which will install both Beta 1+ of the Framework and the database engine itself. There's no need to uninstall the whole of VS 2005, just the .NET Framework itself. Clear as mud?

Once again, apologies if this is blatantly obvious, but perhaps it will save someone ten minutes' frustration.

  • using VS 2005 Beta 1 and Yukon Beta on the same machine - level 100
  • Yeap, I had to uninstall .NET Framework Beta that came with Visual Studio 2005, but didn't touch Visual Studio 2005 at all. Now everything is perfect :)
  • Yes, it is true, you have to uninstall the .net framework.
  • Anyone on the bleeding edge installed VS2005 Beta and SQL 2005 Beta on Longhorn successfully?
  • It depends which release of Longhorn you're talking about, David. The PDC build of Longhorn matches the PDC technical preview build of Whidbey. But for the most recent build of Longhorn (the WinHEC one), you have to use the command-line tools and the Longhorn SDK as the Visual Studio build wasn't generally released.

    I've heard some people who have done it, but it's not recommended to install Yukon on Longhorn at this stage.

    Hope this helps,

    Tim
Page 1 of 1 (5 items)