WinFX Runtime Components Beta 2 and the Dreaded Error 1603

WinFX Runtime Components Beta 2 and the Dreaded Error 1603

  • Comments 2

I've seen a number of instances of this error over the last few days since we released WinFX Runtime Components Beta 2, and wanted to highlight it right here on the blog to ensure people knew about it.

The symptom is that on installing the WinFX Runtime Components on a machine that previously had an earlier release, setup fails to complete during the installation of Windows Communication Foundation, giving a fatal error 1603. This is due to an InfoCard service that we have a problem uninstalling.

It's actually documented in the readme, but I guess I'm not the only one who doesn't pay a blind bit of attention to those! Here's the extract that includes the workaround:

WinFX installation fails with this error:

ERROR_INSTALL_FAILURE 1603 Fatal error during installation

And in one of the %temp%\dd_wcf_retCA*.txt log files, it shows the following:

ServiceModelReg [15:48:08:041]: Installing: Microsoft Digital Identity Service (idsvc)
ServiceModelReg [15:48:08:073]: Error: System.ComponentModel.Win32Exception: The name
is already in use as either a service name or a service display name

To resolve this issue:

  1. Open a command prompt
  2. In the command prompt, type: sc delete "InfoCard Service"
  3. Restart the WinFX Beta 2 installation

Hope this helps out a few folk!

  • I havne another issue preventing my installation.
    Here is the call stack found in a dd_wcf_retCA file:


    === Verbose logging started: 18.06.2006  21:00:49  Calling process: C:\WINDOWS\WinFX\v3.0\Windows Communication Foundation\ServiceModelReg.exe ===
    ServiceModelReg [21:00:50:343]: Error: System.Runtime.InteropServices.COMException (0x800CC810): Unknown error (0x800cc810)
      at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
      at System.DirectoryServices.DirectoryEntry.Bind()
      at System.DirectoryServices.DirectoryEntry.get_AdsObject()
      at System.DirectoryServices.PropertyCollection.Contains(String propertyName)
      at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.PathContainsScriptMaps(DirectoryEntry path)
      at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.IsInstalledAtPath(DirectoryEntry path)
      at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.get_IsInstalled()
      at System.ServiceModel.Install.WebHostScriptMappingsInstallComponent.get_InstallActionMessage()
      at System.ServiceModel.Install.ServiceModelInstallComponent.GetActionString(InstallAction action)
      at Microsoft.Tools.ServiceModel.ServiceModelReg.Run(String[] args)
      at Microsoft.Tools.ServiceModel.ServiceModelReg.TryRun(String[] args)

    Thank you for any hint...
  • i ran the sc delete but there is no infocard service installed or running? Now what?
Page 1 of 1 (2 items)