Demo Failure: A Puzzle with an Amusing Ending

Demo Failure: A Puzzle with an Amusing Ending

  • Comments 7

Tomorrow is the start of the PDC, and while I have a quiet moment before the final keynote rehearsals start, I thought I’d share this little story with you.

I got an urgent email very early yesterday morning as I was just waking up from a colleague who was about to go on stage to do a demo in a Steve Ballmer keynote. The demo showed how IE9 enables web apps to feel more like Windows desktop apps, using features like pinned site mode, jump lists, notification icons and so on. The issue was that the notification icons just weren’t popping up on cue. They’d worked perfectly well the night before during rehearsals, but all of a sudden they weren’t appearing.

Everyone was racking their brains to try and figure out what was going wrong. Had someone tinkered with the demo machine? Had the website changed? I’ve been there before, and you can probably imagine how stressful it is to hit a demo issue so close to a CEO keynote.

imageFrom the relaxed atmosphere of my bedroom, I decided to go have a quick look at the code to see why it was failing. I was amused to discover the source of the issue. Rather than jump straight to the answer, I’ll give you the chance to figure it out for yourself – see how long it takes you, and go ahead and post in the comments section when you’ve figured it out.

The site in question is LiveStrong – co-founded by the Lance Armstrong Foundation. (Hit F12 when you’ve opened the link below to open the IE Developer Tools.)

  • I'm going to guess its because this line was recently added to the site:

    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>

    Because they are emulating IE7, the notification script is no longer working?

  • Good guess, Eric - but no. Actually this site runs in IE9 standards mode: it has the HTML5 doctype and doesn't set a different document mode for compat reasons.

  • Someone clicked the "Don't show these badge pop-ups anymore." checkbox?

  • Would this have anything to do with the display:none for .simple_overlay?

  • Probably they did something wrong with the msapplication-meta-tags.

    At first glance I don't see it, they didn't change it again, I hope ?

    But I'm not really interrested in looking up the syntax right now. The syntax is much more complicated then was necessary: ajaxian.com/.../a-call-for-pinning-menus-sanity

    And Aero is the first thing I turned off, I find it to ugly and distracting. It is silly you only support these features when Aero is on.

  • What a waste of time, just say what it was! Maybe I should stop reading this blog.

  • Looks like notifications only work between 08:00 and 23:00hrs! :)

    ==> if(o.getHours()==8||o.getHours()==9||o.getHours()==10||o.getHours()==11||o.getHours()==12||o.getHours()==13) etc....

Page 1 of 1 (7 items)