Microsoft Dynamics CRM UK Blog

CRM news and views from Simon Hutson

Visual Studio 2008 Hangs After Adding A Web Reference

Visual Studio 2008 Hangs After Adding A Web Reference

  • Comments 4

Sign Of The Times... 

A few weeks ago I came across a problem in Visual Studio 2008, whereby it seemed to hang every time I added a web reference to the CRM web service, and then tried using IntelliSense to discover the attributes of an entity. Looking at the processes in Windows Task Manager, showed that Visual Studio was consuming almost all the CPU cycles, with "devenv.exe" showing 99% CPU utilisation. After approximately 30 minutes, Visual Studio would return to normal, only to hang again the next time I tried to use IntelliSense or even just compile the project.

It turns out that a bug in the way Visual Studio 2008 handles large XML files (such as the CRM WSDL file) causes this behaviour, and simply disabling XML comment generation for each project solves the problem. I found a KB article which describes the problem and the fix in detail here - FIX: You may experience performance issues in the IDE after you use Visual Studio 2008 to build a Visual Basic project.

This posting is provided "AS IS" with no warranties, and confers no rights.

Laughing Boy

Comments
  • Thank you!!!!!!!!  I've been struggling with this half the day!

  • Thank you as well.  I've spent the better part of 3 working days trying to get this to work...and this did the trick.  Awesome.

  • Oh man, I can't thank you enough.  I wish Google would have returned this page to me about 16hrs of debugging, rebuilding, recreating, etc...ugh.  

  • You're most welcome.

Page 1 of 1 (4 items)
Leave a Comment
  • Please add 1 and 5 and type the answer here:
  • Post