Eclipse shows an error on android project but can find the error

Eclipse shows an error on android project but can find the error

  • Comments 8

My favorite Android platform on which I can blog so much since its just full of strange behaviors. Latest was this problem where when I build my project then I would see a red mark on the project folder saying the build failed. But then on exanding all folders I would not find any error.

I was looking everywhere what is the problem. Since I am not using ANT and I dont even have a build.log which can tell me exactly what is the problem. In the past following had worked

1) Clean the project

2) Build it again.

No success.

1) Close eclipse and repeat above two steps.

That had worked in the past but this time the error was nasty :).

So I spent some time searching on net on how to find eclipse build logs. And here is the solution.

1) On Eclipse error log can be seen in Window -> Show View -> Problems

2) Now if you are like me who has selected Project -> Build Automatically, then on startup eclipse tries to load all projects in the workspace and will try to build them if they havent been already. The effect is that I have many projects for which external reference have not been resolved. This means they have lots of errors and the Problems log was full with > 3000 errors.

3) I needed to find the error for only my project. Solution for 2 is that clean all projects and unselect Build Automatically option.

4) If Problems log is still full. Right click-> Select all. Then Right click -> Delete. Now Problems log must be empty.

5) Build only your project again to see the problem.

 

So as is I got this funny error. Error generating final archive: Debug certificate expired on 7/30/10 10:42
PM!
Now what, another search on the web told me that Android needs a certificate to sign the applications before they get installed. Oh well!

So the solution to my problem was. Go to c:\users\<user name>\.android    folder. Delete debug.keystore file and now build in eclipse again. It will create the keystore again and now we can get back to work!!

Comments
  • Welcome to my site http://kyquan.info

    KYQUAN.INFO - when the music PLAY

    MOVIE, FILM, MUSIC, IT...Everything 2 share ! ^^ - welcome every body !

  • Doing very well! Thank you to share! I recommend here!   http://www.hpurl.com/9849848

  • exactly the problem I was having. TYVM!

  • Thanks.  I spent so much time tried to clean and debug the project and finally I 've exactly the same problem as yours.....  THANKS !

  • thnanks...it works

  • in the error will be found

    "Starting emulator for AVD 'AVD_for_Nexus_4_by_Google'

    emulator: WARNING: Requested RAM size of 1907MB is too large for your environment, and is reduced to 1072MB.

    Failed to allocate memory: 8

    This application has requested the Runtime to terminate it in an unusual way.

    Please contact the application's support team for more information."

  • i had same problems i did same as mentioned above but nw its showing errors..and cant b executed

    .

  • great resolving problem !! Thank you very much :)

Page 1 of 1 (8 items)
Leave a Comment
  • Please add 3 and 3 and type the answer here:
  • Post