image

Quite a lot of you guys are trying to use the “Windows Identity Foundation and Windows Azure passive federation” lab (available in the Identity Developer Training Kit, Windows Azure Platform Training Kit and standalone) with the latest version of the Windows Azure Tools for Visual Studio. The dependency checker in the versions of the lab currently available, however, checks for the November release of the Windows Azure tool and gets quite upset if it doesn’t find it.

Eventually we are going to release new versions of the above with updated system requirements, but if you want to go through the lab TODAY with the latest Windows Azure bits all you need to do is changing one of the cmdlets in the setup:

Current CheckAzureToolsForVS.ps1 file:

$res1 = SearchUninstall -SearchFor 'Windows Azure Tools for Microsoft Visual Studio 2008 1.0*' -SearchVersion '1.0.21016.3' -UninstallKey 'HKLM:SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\';

Fix to apply on CheckAzureToolsForVS.ps1 file:

$res1 = SearchUninstall -SearchFor 'Windows Azure Tools for Microsoft Visual Studio 2008 1.*' -SearchVersion '1.0.21016.3' -UninstallKey 'HKLM:SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\';

Note, the requirement for VS2008 still stands.

Happy HOL-ing!