SCCM 2007 Charting functionality does not work on 64 bit IIS

SCCM 2007 Charting functionality does not work on 64 bit IIS

  • Comments 8

System Center Configuration Manager (SCCM) has a nice functionality of displaying report data as charts.  When deployed on a 64 bit IIS 6.0 machine these chart displays may stop working and you will start getting the following error message.

This report has a chart, but the Microsoft Office Web Components required to view charts are not installed on the Reporting Point. Please contact your administrator.

SCCM uses Office Web Components (OWC) to display these charts. First you need to ensure that you have Office Web Components 11 installed

But even after installing OWC you may keep getting the error message. The limitation with OWC is that it only ships in a 32 bit version. It does not have a 64 bit version. If your IIS worker process is running in 64 bit mode it will not be able to load the 32 bit OWC dlls. So even though you have OWC installed the SCCM web application will complain that you do not have OWC. To get this working you need to make the IIS worker process run in 32 bit mode. You do this by changing a metabase setting.

Click Start, click Run, type cmd, and then click OK.

Type the following command to enable the 32-bit mode:

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

Now since the IIS worker process is running in 32 bit mode we need to ensure the ASP.NET ISAPI filter is also changed to the 32 bit version.

Type the following command to install the version of ASP.NET 2.0 (32-bit) and to install the script maps at the IIS root and under:

%SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe –i

Make sure that the status of ASP.NET version 2.0.50727 (32-bit) is set to Allowed in the Web service extension list in Internet Information Services Manager or else ASP.NET pages will return a 404 error message.

Note that your IIS worker process is now running in a 32 bit mode. So you need to ensure you do not have any 64 bit ISAPI filters or script maps as they cannot load in a 32 bit process.

Also on IIS 6.0 all worker processes either run in 32 bit mode or 64 bit mode. With IIS 7.0 you can set the bitness to a specific application pool.


Bookmark and Share

Leave a Comment
  • Please add 2 and 1 and type the answer here:
  • Post
  • PingBack from http://www.clickandsolve.com/?p=7095

  • System Center Configuration Manager (SCCM) has a nice functionality of displaying report data as charts. 

  • I looked all over to get this to work and this is the only soluton that does the trick.  The first task to enable 32-bit IIS is all over the place but the command to register ASP again was missing.  Thanks for your help, everything is working great now.  

  • System Center Configuration Manager (SCCM) has a nice functionality of displaying report data as charts

  • once the steps mentioned in the article are taken,

    can they be undone if needed to go back to the normal

  • This procedure should not be executed because OWC is for 32-bits only and is not supported on 64-bits. If you switch between the ASP.Net versions, you can face issues with the application pools (i.e SMS Management Application Pool) causing internal errors  (Internal error 500) in the mpcontrol.log, If you are affected, you will need to rollback any changes and not try to reinstall 32-bit version of OWC.

    Below are the commands to rollback the changes and switch back to 64-bit version of ASP

    1. cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

    2. %SYSTEMROOT%\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

    After this commands, the mpcontrol.log will show back status code 200, text: OK

  • Worst Solution, not applicable for Windows 2008 R2, it causes Reporting issues, dont use this

    Saad

  • Ok.  I need help.  I do have 2008 r2 and did fall victim to running the commands.  I have tried to roll back the commands using Luis Pinzon's Suggestions but i am unable to pull up the site now?  anything special i need to do to get things working again?  Any help is greatly appreciated.

Page 1 of 1 (8 items)