Weird monitor error with SuSE under Virtual PC / Virtual Server

Weird monitor error with SuSE under Virtual PC / Virtual Server

  • Comments 3

If you install SuSE 9.0 or later under Virtual PC / Virtual Server - you will get the following error message when you first log in:

“Your monitor didn’t report its X- and Y- Size, this might cause display problems like unreadable fonts... Do you want to configure your monitor geometry manually?”

It turns out that the reason for this error is that the S3 Trio video card that we emulate does not support returning of monitor dimensions.  Thankfully I keep a physical computer around which has the same hardware as we emulate (S3 Trio, DEC 21140, Sound Blaster 16) so I was able to confirm that this is expected behavior with this hardware.  You should be able to just select 'No' on this dialog and be fine - however if the dialog continues to appear you can get rid of it by manually specifying false dimensions for the 'virtual' monitor.

Cheers,
Ben

Leave a Comment
  • Please add 6 and 1 and type the answer here:
  • Post
  • Too late! :-(

    I just clicked "yes" and now Suse Linux 9.1 stops responding.

    Any suggestions?

    Greetings
    Peter
  • As you have a computer with the same hardware as a VM does ghosting a VM and putting it on the physical machine work fine? Also does it work the other way round?
  • No, I have no other computer with the same hardware.

    It was only a test so it is not important.

    Thanks for your help! :-)

    Peter
Page 1 of 1 (3 items)