Updated Virtual Machine Additions for Linux available

Updated Virtual Machine Additions for Linux available

  • Comments 20

There are new Virtual Machine Additions for Linux available for download.  There are two key changes to be aware of:

  1. Addition of support for SuSE Enterprise Linux 10.  The official supported list is now:
    1. Enterprise distributions

      • Red Hat Enterprise Linux 2.1 (update 6)
      • Red Hat Enterprise Linux 3 (update 6)
      • Red Hat Enterprise Linux 4
      • SuSE Linux Enterprise Server 9
      • SuSE Linux Enterprise Server 10
      Standard distributions
      • Red Hat Linux 7.3
      • Red Hat Linux 9.0
      • SuSE Linux 9.2
      • SuSE Linux 9.3
      • SuSE Linux 10.0

    1. The download is no longer on connect.microsoft.com and does not require any registration (yay!).  You can easily download it from here: http://www.microsoft.com/downloads/details.aspx?familyid=bf12642f-77dc-4d45-ae4e-e1b05e0a2674&displaylang=en&tm

    As always - this is only supported on Virtual Server - but should work just fine on Virtual PC.

    Cheers,
    Ben

    Leave a Comment
    • Please add 4 and 4 and type the answer here:
    • Post
    • Thanks.

      I see that the Virtual Server TechCenter page has been amended away from Microsoft Connect

      towards Microsoft Downloads.

      Hopefully someone will update the Microsoft Connect site, at least putting something in the "news" so that people know 1.2 is no longer the latest.

    • Hi Ben,

      is there any hope to get virtual machine additions for debian in the future? That would be amazing :)

      Jan

    • Dave English - Good point, I will see if we can get the Connect site updated.

      Jan - I do not know, but have you tried using the shell scripts on Debian to see if they work?

      Cheers,

      Ben

    • It's worth noting, particularly for the person asking about Debian above, that there is very little of this which is actually distro-specific.  The files installed in /etc/init.d die if they don't recognize one of the supported distros, but a little judicious editing can add at least some support for your distro of choice.  Most of the detection logic is to determine which path is correct for the current system -- you'll have to determine that by hand and write it into the file.

    • FYI I have Centos 4.x running under the (now older) additions perfectly in VPC 2007. Great for testing upgrades before I apply to my production server which of course one thing VS/VPC is perfect for...

      John

    • We really need a debian version! Please, show us mercy... or, if thats impossible, at least open the source so somebody could do it.

    • Do you get the 64-bit additions if you're running Virtual PC for 64-bit Windows?

    • Stuart P. -

      No.  Virtual Server / Virtual PC only support 32-bit virtual machines.  The 64-bit package is just so you can install the bits on a 64-bit host OS.

      Cheers,

      Ben

    • Does the 64-bit package disable Intel's Virtualization Technology or is there some other reason why VT is unavailable?  As far as I can tell from Intel's site, T7200 has VT hardware.

    • Norman:

      Do you have VT enabled in the BIOS? VT is off by default on non-server class machines.

    • Debian/Ubuntu folks.

      there is a recipe for installing the VMAdditions for Linux at

      http://ubuntuforums.org/showthread.php?t=434039

      It seems to be working on my Ubuntu 6.06LTS  install, although timesync not quite as advertised.

    • Sunday, November 04, 2007 12:05 AM by Scott Allen

      > VT is off by default on non-server class machines.

      I guess that explains why that notebook's BIOS doesn't mention VT.  I wonder what the vendor's purpose is in crippling their hardware.

    • I installed Debian Etch in a guest under Virtual PC 2007.  Edited /etc/X11/xorg.conf and set the default bit depth to 16 in order to get started.

      On the physical machine, I installed VMAdditionsForLinux_64Bit.msi and it worked (so I don't think the download was corrupted).  I found the resulting .iso image, and in the guest CD menu's settings I captured the .iso to the guest's CD drive.

      In the Debian guest's desktop, an icon appeared for the CD drive, VMAdditionsForLinux.  I opened it and there are no files in it.

      I opened a Gnome Terminal, cd'ed to /media/cdrom, and did an ls -la.  It agreed that there are no files in the .iso image.

      Any ideas?

    • Some idiot asked:

      > Any ideas?

      Yeah, reboot.  That solves everything.  This one too.

      [Nitpicker's corner:  Rebooting doesn't solve everything, it just solved this one.]

    • The posting on the Ubuntu forums (http://ubuntuforums.org/showthread.php?t=434039) from Tom's comment worked for my Debian Etch install.  No more clock drift!  However, I didn't notice any improvement in X performance.

    Page 1 of 2 (20 items) 12