(2013 Mar 3 – Updating the work around steps. Also, when Update 2 RC is available, you can always install that to fix your problem)

For those of you installing the VS Update 2 – CTP3, there is an installation sequence that will put the web access work item tracking in a state where editing work items displays this error:

clip_image001

 

If you install

  • VS 2012 RTM
  • VS 2012 – Update 1
  • VS 2012 – Update 2 – CTP3

and

  • TFS 2012 RTM
  • TFS 2012 Update 1

but do not install

  • TFS 2012 Update 2 – CTP3

and your VS is installed on the same box as your TFS Server,

You can run into a situation where your DLLs are mismatched and you receive the above error.

Your workaround is to follow these steps:  

  1. msiexec /uninstall "C:\ProgramData\Package Cache\{21A32668-4A9D-3F8F-A9B7-02848DD5337B}v11.0.60204\packages\TFSObjectModel\x64\core\TFSObjectModel-x64.msi"
  2. msiexec /uninstall "C:\ProgramData\Package Cache\{7A5DB6D6-926A-3E9B-B1DA-F579AEF00EA0}v11.0.60204\packages\TFSObjectModel\x64\enu\TFSObjectModelLP-x64_ENU.msi"
  3. From Programs and Features, search for and find your installation of Team Foundation Server, and then select Repair

This will revert TFS OM to match the version of the TFS Server, and your DLLs should be in synch again.

This is all be tracked under this Connect bug: http://connect.microsoft.com/VisualStudio/feedback/details/779130/team-foundation-server-2012. (Thank you to Mr. Clarkson for reporting this bug)

We will fix this bug, before VS Update 2 and TFS Update 2 goes RTM.