Recently, we found a bug that hidden in the WCF RIA Services RC release setup authoring, which causes the Data Source Window cannot populate RIA Services Domain Context objects, and the Live IntelliSense doesn’t work. This only happens when the VS2010 is not installed in the default VS installation path. For example, if your default system root is C:\ (then the default path will be under C:\$(Program Files)\Microsoft Visual Studio 10.0...), while you install the VS2010 into D:\, then you would meet with the issue. The setup authoring in this case doesn’t install some feature assemblies into the right location. We feel very sorry to find this issue so late and will fix it in WCF RIA Services RTW, and meanwhile, you could try the following workaround to get it work.

The workaround is to copy the feature assemblies installed into the wrong location to your machine to the right path. The feature assemblies now are always installed in your system root under $(ProgramFiles)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\RiaTools, which includes two folders of Data Binding and Live IntelliSense. And you’ll have to keep this folder structure and copy them into where you installed your VS2010.

For example, if your system root is C:\, and your $(Program Files) is Program Files, then those assemblies are installed at C:\Program Files\ Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\RiaTools. If your VS2010 is installed at D:\Program Files\Microsoft Visual Studio 10.0, then you will need to copy these assemblies under this path: D:\Program Files\ Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Microsoft\RiaTools. There might be some folders missing in your VS2010 installation path, and you will need to create the corresponding folders for it.

Hope it helps.