The following steps could be tried:   Please verify that Framework 2.0 is installed properly. You might want to start with .NET Framework setup verification tool. The .NET Framework setup verification tool is available for download at the following location:




You can do the following to locate this type of error in the application event log:


1.      Click on the Start menu, choose Run, type eventvwr and click OK

2.      Click on the Application log on the left side of the Event Viewer

3.      Locate the application event log entries with time stamps that match the time stamps of the custom action listed in the verbose MSI log files

4.      Look for errors with the source value set to System.ServiceModel.Install (this is the assembly that is loaded by ServiceModelReg.exe to perform the registration that it needs to do)


Step -2
Check the following registry keys. Please delete them after taking backup
i. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSDTC Bridge\Performance
v. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SMSvcHost\Performance

Command Prompt
1. In the command prompt, type: sc delete “InfoCard Service"
2. Reboot the machine

Run the WMI diagnostics and repair tool available at to repair the WMI service.
A description of the tool is available at
Rerun the .NET Framework 3.0/3.5 setup utility

Remove the stale machine.config entries by hand
a. From a command window run “notepad
Remove any xml nodes and child nodes that reference System.ServiceModel.dll

1. Uninstall IIS.
2. Re-install IIS.
3. Re-run .NET Framework 3.0 setup



Content by: Soumitra Mondal