During the installation of  .Net framework 3.5, you will see an error as shown below in the setup error log file. . As the installation of .Net framework 3.5 is dependent on .Net framework 3.0 and 2.0, you might see these kind of errors very frequently.

===============================================================================================================================

9/09,12:49:05] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.

[08/19/09,12:57:01] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603

[08/19/09,12:57:06] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

================================================================================================================================ 

This indicates that the installation is failing on one of the .Net framework 3.0 component. Download the full package of .Net framework 3.0 from the following location
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043 (scroll down the page to find the instructions part of the page)

 

Initiate the installation of .Net framework 3.0 and the if the setup fails with the following code, execute the steps following.

 

====================================================================================================================================

9/09,13:07:51] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603

[08/19/09,13:07:55] WapUI: [2] DepCheck indicates Windows Communication Foundation is not installed.

 

Extract .Net framework 3.0 in the command line prompt (<exe> /extract) . you will find a WCF folder under which you will find the wcf.exe

Execute the wcf.exe and you will see the following error

 ====================================================================================================================================

 

(Action=DD_CA_InstallXwsRegExe_RB_X86.3643236F_FC70_11D3_A536_0090278A1BB8,ActionType=3393,Source=BinaryData,Target=QuietExec,CustomActionData=C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe /u /x /y /v;dummy;C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\)

MSI (s) (9C:88) [13:14:08:531]: Executing op: ActionStart(Name=DD_CA_InstallXwsRegExe_X86.3643236F_FC70_11D3_A536_0090278A1BB8,,)

MSI (s) (9C:88) [13:14:08:531]: Executing op: CustomActionSchedule(Action=DD_CA_InstallXwsRegExe_X86.3643236F_FC70_11D3_A536_0090278A1BB8,ActionType=3073,Source=BinaryData,Target=QuietExec,CustomActionData=C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe /r /x /y /v;dummy;C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\)

MSI (s) (9C:38) [13:14:08:531]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIC5.tmp, Entrypoint: QuietExec

MSI (s) (9C:18) [13:14:08:546]: Generating random cookie.

MSI (s) (9C:18) [13:14:08:546]: Created Custom Action Server with PID 1408 (0x580).

MSI (s) (9C:B0) [13:14:08:593]: Running as a service.

MSI (s) (9C:B8) [13:14:08:593]: Hello, I'm your 32bit Elevated custom action server.

MSI (s) (9C:88) [13:14:23:609]: User policy value 'DisableRollback' is 0

MSI (s) (9C:88) [13:14:23:609]: Machine policy value 'DisableRollback' is 0

Action ended 13:14:23: InstallFinalize. Return value 3

Note the custom action that is failing (highlighted)

Go to properties of Mycomputer, click the Advanced tab and Environment Variables.

Create a user Variable with the name MSIBreak and value = DD_CA_InstallXwsRegExe_X86.3643236F_FC70_11D3_A536_0090278A1BB8

Run wcf.exe and the MSI installation will break at the custom action. Don’t respond to the dialog box .

Open the command prompt window and execute the following command manually –“ C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe /r /x /y /v;dummy”

Got the following error

====================================================================================================================================

Unhandled Exception: System.TypeLoadException: Could not load type 'System.ServiceModel.Install.EventLogger' from assembly 'System.ServiceModel.Install, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. at Microsoft.Tools.ServiceModel.ServiceModelReg.TryRun(String[] args)at Microsoft.Tools.ServiceModel.ServiceModelReg.Main(String[] args)

====================================================================================================================================

 

Go to the assembly folder under c:\windows and uninstall the “system.servicemodel.install” assembly

Now click on cancel on the MSI dialogbox.

Uninstall the WCF installation and reinstall .Net framework 3.0

Once .Net framework 3.0 is installed successfully, install .Net framework 3.5

 

Possible Root Causes:

1) System.ServiceModel.Install  with the current version, culture, public key token was not found

2) One of the dependencies is missing

 

Content by :Dhathri P