Issue

=========

.NET Framework 3.5 SP1 installation fails with error :

---------------------------
Microsoft .NET Framework 3.5 SP1 Setup
---------------------------
The Windows Installer package:

c:\95a81ae6b7710d0be9e6ff093daf\vs_setup.ms_ could not be opened.


Choose Retry to try again. Choose Cancel for exit setup.
---------------------------
Retry Cancel
---------------------------

and
---------------------------
Microsoft .NET Framework 3.5 SP1 Setup
---------------------------
A problem has been encountered while loading the setup components. Cancelling setup.
---------------------------
OK
---------------------------


Resolution

=========

 

- Enabled verbose logging in Registry and then tried the install of .NET 3.5 SP1


MSI LOG
==========
MSI (c) (4C:00) [18:26:56:964]: Note: 1: 2262 2: AdminProperties 3: -2147287038
MSI (c) (4C:00) [18:26:56:964]: Machine policy value 'DisableMsi' is 2
MSI (c) (4C:00) [18:26:56:964]: Machine policy value 'AlwaysInstallElevated' is 0
MSI (c) (4C:00) [18:26:56:964]: User policy value 'AlwaysInstallElevated' is 0
MSI (c) (4C:00) [18:26:56:964]: Product installation will be elevated because user is admin and product is being installed per-machine.
MSI (c) (4C:00) [18:26:56:964]: Rejecting product '{CE2CDD62-0124-36CA-84D3-9F4DCF5C5BD9}': Msi is completely disabled.
Info 1625. This installation is forbidden by system policy. Contact your system administrator.
c:\2ec1fce8c19d0b7f59ac561dd9edfe\vs_setup.ms_
MSI (c) (4C:00) [18:26:56:964]: Note: 1: 1708
MSI (c) (4C:00) [18:26:56:964]: Note: 1: 2729
MSI (c) (4C:00) [18:26:56:964]: Note: 1: 2729
MSI (c) (4C:00) [18:26:56:964]: Product: Microsoft .NET Framework 3.5 SP1 -- Installation failed.

- Found that while extracting files in a random folder in C drive it is trying to run vs_setup.ms_ instead of vs_setup.msi
- "_ " is replacing the .msi format
- Found that a Regkey "DisableMSI" was added to HKLM\Software\Policies\Microsoft\Windows\Installer
- Renamed that key and tried the install and then we were able to .NET Framework 3.5 got installed without any issues

 

Content by: Amit Sharma

Reviewed by: Soumitra Mondal