While installing .Net framework 2.0, you may get the above mentioned error. For resolution on how to fix this, please refer to the following link

 

http://blogs.msdn.com/b/smondal/archive/2010/07/12/quot-25007-error-occurred-while-initializing-fusion-setup-could-not-load-fusion-with-loadlibraryshim-error-the-handle-is-invalid-quot.aspx

 

 

content by : Soumitra Mondal