Note: Cross posted from Rubel's Blog.
Permalink

You may find sometimes that video log (.wmv) generated by Video Recorder data collector is not proper and doesn’t playback anything when you try to play it back. You won’t see any error message / warning from Video Recorder data collector in that scenario so it becomes hard to figure out what exactly is wrong.

You can check for video file size in test result viewer in MTLM and if you find that it is approximately ~12KB then this means that you are running into the issue which I am describing below:

image

This problem generally happens if you’ve enabled Video Recorder data collector for a remote role BUT:

  • Test Agent is NOT set up to run as a process. To resolve this, Please follow the steps listed here to run test agent as a process.
  • Test Agent was running as process but desktop session was NOT active which can happen for a number of reasons like:
    • Test Agent box was locked during test execution
    • Screen Saver was enabled on Test Agent box and it got active during test execution
    • You were connected to Test Agent box using RDP connection but its session was minimized during test execution.

So please make sure that desktop session of Test Agent box is active during test execution.

If you take care of above mentioned things then you should get a proper playable video log (.wmv) from Video Recorder data collector. You may refer to my earlier post on Video Recorder Data Collector if you are looking for details on other pre-requisites of Video Recorder data collector.

Note: Cross posted from Rubel's Blog.
Permalink