Fácilmente podría decir que esta actualización es la más drástica de todas las ocurridas a Windows Azure desde su lanzamiento. Si no la más drástica, es la que más novedades nos ha traído en una sola entrega.


Coincidiendo con el PDC10 ocurrido en el campus de Microsoft Corporation en Octubre de este año, numerosos anuncios se hicieron públicos acerca de nuestra plataforma de cloud.


La aparición de un nuevo rol: El VM Role que le da el sabor de IaaS a Windows Azure, los permisos elevados para los roles, el acceso full para IIS, el nuevo tamaño de máquina XSmall, la evoluación del AppFabric, la puesta en producción del Data Marketplace (antes Dallas) , el advenimiento de un Windows Azure Marketplace, mejoras para SQL Azure como Reporting Services, etc.


Todo lo anterior sumado al proceso lógico de evolución del código, conllevó a algunos cambios también en las librerías del SDK. Y precisamente de esto estaremos hablando en este artículo.


Si ud. había venido trabajando con la versión 1.2 de los tools de Windows Azure, lo único que tiene que hacer es desinstalarlos e instalar la versión 1.3. Tenga en cuenta que si instala la 1.3 sobre la 1.2 sin haberla desinstalado manualmente, la anterior no se desinstalará y el sistema no funcionará correctamente.

Cuáles son las principales diferencias?

En esencia las de más impacto son dos: 1. La inclusión de manejo de FULL IIS. 2. Cambios en el API de acceso al storage (StorageClient.dll).


Así que ya instalamos y tenemos andando correctamente la versión 1.3 tanto del SDK como de los tools. En ese caso apenas tomamos una solución 1.2, aparece un asistente de migración de nuestro proyecto.


Qué cosas hace? Básicamente cambia la versión de producto en el .csproj del proyecto cloud a 1.3.0.0 y agrega la sección de Sites al archivo de configuración de los web roles para indicar que se usará la característica de Full IIS. Esos son los cambios.
Qué puede fallar?


Primero puede que obtenga esta excepción: “Could not load file or assembly 'Microsoft.WindowsAzure.StorageClient, Version=1.0.0.0“ . Solución en este post.


Lo otro que puede pasar, es que obtengamos la excepción: “SetConfigurationSettingPublisher needs to be called before FromConfigurationSetting can be used”; para ver detalles de este error y cómo solucionarlo vea este post.