If you see "The Month parameter must be in the range 1 through 12." thrown using the 1.0 version of the Exchange Managed API when dealing with non-DST timezones, then you should look at upgrading to the 1.1 version of the Exchange Managed API - the issue should be fixed in that version.