Downloadable Hotfix: Publish command fails when Virtual Path is set to /

Downloadable Hotfix: Publish command fails when Virtual Path is set to /

Rate This
  • Comments 8

One of the convenient new things in Visual Studio 2005 SP1 is the ability to set the built-in ASP.NET Development Server to use "/" as the Virtual path for when it runs.  This is very useful for development of web apps that will eventually be deployed to the root folder of a web server, or for web applications that use server root relative URLs (e.g. - "/images/foo.jpg").

However, when you set the Virtual path of the built-in development server to "/" for a Web site, you may encounter an issue with the Publish Website command not working.  This may result in either of the following error messages:

 

I'm glad to announce that our team has a hotfix available for download that fixes the above described issue.  If you are running into this problem after installing Visual Studio 2005 SP1, please download the hotfix and that should make the Publish Website command work as expected.

On a related note, both Visual Studio and the .NET Framework make all high-impact hotfixes available for download at the following website: https://connect.microsoft.com/VisualStudio/Downloads.

Hope this information helps!

Cheers,

Omar Khan
Group Program Manager
Visual Studio Web Tools

 

  • Two weeks ago I posted about the availability of a public hotfix patch for some ASP.NET 2.0 compilation

  • Two weeks ago I posted about the availability of a public hotfix patch for some ASP.NET 2.0 compilation

  • Two weeks ago I posted about the availability of a public hotfix patch for some ASP.NET 2.0 compilation

  • When installing in Vista with Visual Studio 2005 SP1 does not work. After installing the hotfix the error still comes up. I don't think it is replaceing the file mswebprj.dll with the correct version.This is what is it suppose to be per microsoft's site Mswebprj.dll 8.0.50727.813 1,329,152 28-Feb-2007 07:24 x86. But when looking at the file after installing the hotfix i get this information Mswebprj.dll 8.0.50727.867 1.26 MB (1,330,688 bytes) 22-Feb-2007  You should look into this.

  • Hello "Test",

    Thank you for reporting the issue with installing on Vista.  We have confirmed the issue (it occurs if you have the VS2005 update for Vista installed) and are working on an updated patch.  Please look for an update from me on this blog in a week or so.

    --Omar

    Group Program Manager

    Web Tools

  • I am glad to announce that an updated version of a Publish Website hotfix for VS 2005 SP1 is now available

  • Hi "Test",

    You can find the updated hotfix here:

    https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=6178&wa=wsignin1.0

    -Alison

  • I am glad to announce that an updated version of a Publish Website hotfix for VS 2005 SP1 is now available

Page 1 of 1 (8 items)