Orcas Beta2 Gotcha: No ASP.NET controls in toolbox, no ASP.NET intellisense/validation on pages

Orcas Beta2 Gotcha: No ASP.NET controls in toolbox, no ASP.NET intellisense/validation on pages

Rate This
  • Comments 47

We’ve heard a few reports of cases with VS Orcas Beta2 where ASP.NET controls do not show up on the toolbox and ASP.NET tag intellisense and validation is broken in HTML source view.  All of the cases reported so far have been with Vista.  The root cause of this is that the Orcas Beta2 version of System.Web.Dll did not get installed correctly on the machine due to interference with some of the .NET Framework Hotfixes that were on the machine earlier.

 

The recommended workaround is to uninstall VS Orcas Beta2, uninstall any .NET Framework 2.0 or 3.0 Hotfix that you have installed on your machine and then reinstall VS Orcas Beta2 .  All released Hotfixes of the Framework have been rolled into Orcas Beta2 so this will not regress your functionality or put your machine in a vulnerable state. 

 

Here are the steps for you to take in order to uninstall your .NET Framework Hotfixes.

 

1.       Go to Start -> "Control Panel" -> Under Programs "Uninstall a program"

2.       Click on View Installed Updates

 

 

 

 

3.       Right click on any of the following KBs that you see and select “Uninstall”.  You will see these listed as "Hotfix for Microsoft Windows (KBxxxxxx)" or "Security Update for Microsoft Windows (KBxxxxxx)".

 

KB110806 

KB925272
KB925369
KB925492
KB927888
KB928208
KB928870

KB929300
KB929916

KB930264
KB931338
KB932394
KB932471
KB932816
KB934529
KB934839
KB935315
KB936707
KB939783

4.       Reboot your computer before installing (or reinstalling) VS Orcas Beta2.

 

This should fix the issue for you.  In case it doesn't for some reason, do let us know.

 

Thanks,

 

-- Bash

 

  • Hi

    well, I tried this - it took a few hours, but made no difference. I am sure I got rid of all of the updates, including all of the KB articles you referenced, but I still have no toolbox or intellisense.

    Just checked through my installed updates, and none of the above are there.

    In terms of Visual Studio stuff already installed, I uninstalled everything related to previous development environments and the above KBs before reboot, apart from AJAX 1.0

    So, a few hours of no luck here

  • Do you think maybe it has to do with VS settings in the registry that does not get removed when you uninstall?  I know when I installed mine, there were a few settings messed up such as line number enabled in my code windows.  Probably be a good time to try reseting the VS environment (I do not remember what the command line option for that was at the moment).

  • Glyn,

    The command line option is devenv /resetsettings.  You can give that a try, however I believe that you may still have a setup issue on your configuration.  Can you email me at bash-at-microsoft.com and I'll put you in touch with our setup team.

    Thanks,

    -- Bash

  • Hi

    i tried the reset option, but that didn't help. Email is winging its way over in a few minutes.

    Glyn

  • It has been a little over a week since we released Beta 2 of VS 2008 and .NET 3.5 . So far the feedback

  • It has been a little over a week since we released Beta 2 of VS 2008 and .NET 3.5 . So far the feedback

  • It has been a little over a week since we released Beta 2 of VS 2008 and .NET 3.5 . So far the feedback

  • Followed these steps as well, but didn't seem to fix the problem. Am running VS 2005 on Vista. None of the hotfixes above are installed.

  • Just to clarify, I'm running both VS 2005 and VS 2008 Beta 2 on Vista. Not receiving any toolbox items except for HTML when I create a new web site.

  • Do we perhaps need to also run aspnet_regiis -i from the 3.5 directory?

    If so, would that suffice over reinstalling all of Visual Studio after uninstalling those hotfixes? On Beta 2's release, I lost a whole day uninstalling Orcas Beta 1, reinstalling Visual Studio 2005, reinstalling VS2005 SP1, and then installing Beta 2. I'm not going through that again.

  • 【原文地址】 Fixes for Common VS 2008 and .NET 3.5 Beta2 Issues 【原文发表日期】 Saturday, August 04, 2007 12:10 PM

  • Description of this issue Since Visual Studio 2008 beta 2 and the .NET Framework 3.5 beta 2 were released,

  • Jon -- It doesn't look like the aspnet_regiis idea will work. Couldn't find a version specific to 3.5; it just kept installing 2.0.

  • This issue also occurs under Longhorn Beta 3.

  • I also reinstalled and had the same problem. Can i do anything to help with this?

Page 1 of 4 (47 items) 1234