Framework .NET 3.5 Sp1 required for targeting frameworks 2.0, 3.0 or 3.5 (multi-targeting) using Visual Studio 2010

Framework .NET 3.5 Sp1 required for targeting frameworks 2.0, 3.0 or 3.5 (multi-targeting) using Visual Studio 2010

  • Comments 5

We have had some customers ask why they are unable to target earlier frameworks .NET 2.0, 3.0 or 3.5 using Visual Studio 2010. Targeting earlier frameworks (also known as Multi-targeting) is in-fact fully supported in VS 2010, but there is a pre-requisite that .NET Framework 3.5 Sp1 must be installed on the machine for VS 2010 to be able to target any of the earlier frameworks 2.0, 3.0 or 3.5.

During VS 2010 installation, only the latest 4.0 version of the .NET framework will be installed on your machine as part of the Visual Studio installation. So if 3.5 Sp1 was not already present on your machine, you will see only the .NET Framework 4 in the target framework dropdown of the New Website / New Project dialogs (In these dialogs, framework dropdown is available in VS Professional and higher skus only) when creating a new website or in the property pages when changing the target of an existing website (In property pages, framework dropdown is available in the VWD Express sku as well). You can click on the ‘More Frameworks’ link and that will take you to the download page for .NET 3.5 Sp1 (see Figure 1).

Figure 1

image

Once .NET 3.5 Sp1 is installed on your machine, restart Visual Studio and you should be able to see the lower frameworks .NET 2.0, 3.0 and 3.5 in the Visual Studio dropdowns (see figure 2).

Figure 2

Figure4

Multi-targeting – Learn More

To learn about the multi-targeting capabilities of Visual Studio 2010, see our earlier blog posts and MSDN documentation:

 

Thanks,
Bala Chirtsabesan | Visual Web Developer Team

Leave a Comment
  • Please add 1 and 1 and type the answer here:
  • Post
  • I cannot find a definitve answer anywhere...is multi-targeting supported in VWS2010? I have 3.5 Framework installed, but I do not get the dropdown to slect earlier versions.

  • hi Dave,

    Was your question regarding VWD Express 2010? If you have the framework 3.5 <b>Sp1</b> installed, then multi-targeting is supported in VWD Express and in VS Professional and higher skus.

    Similar to VWD Express 2008, with VWD Express 2010, you do not have the dropdown available when you create a new website. It will create a 4.0 project by default when you create a new website, but you do have the option to go to the property pages and change the target to an earlier framework version. With VS 2010 Professional, you can select earlier framework versions when creating new websites as well.

    Hope this helps,

    Bala Chirtsabesan | Visual Web Developer Team

  • You bring up good points regarding the frameworkMoniker attribute and having a simple web.config to start with when we create a new 4.0 project. Both of these are under consideration to be fixed for the Beta 2 release of Visual Studio 2010.

  • With VS 2010 Professional, you can select earlier framework versions when creating new websites as well.

  • It will create a 4.0 project by default when you create a new website, but you do have the option to go to the property pages and change the target to an earlier framework version.

Page 1 of 1 (5 items)