Why don't Beta 2 sites work on RC0 - Question of the Day

Why don't Beta 2 sites work on RC0 - Question of the Day

Rate This
  • Comments 8

Technorati Tags:

del.icio.us Tags:

 

I've been getting a lot of questions and confusion around why you get the following strange behavior.

"I've installed the RC0 developer runtime, and whenever I hit a Beta 2 site, I get the 'install badge' instead of my site. If I click this badge to install I can't because I'm told I already have a newer version. What gives?"

 

When the browser sees an <OBJECT> tag, it looks at the type parameter to see what it should use to render the object. Silverlight Beta 2 uses the following: type="application/x-silverlight-2-b2" , Silverlight RC0 (and later RTW) uses the following: type="application/x-silverlight-2"

So, if you have RC0 installed, and you hit a beta site, the browser sees the '-b2' type tag, and doesn't have a Silverlight object that understands it, so it renders the install badge (as per the rules in Silverlight.js), and this install badge links you to the B2 installer. As you have a newer version, you get an error.

RC0 is a developer runtime, so there is no public link to it, and the badge links to the end user runtime of Beta 2. When we RTW the link will be updated to the RTW end user runtime, and the problem will go away.

The process to follow, for your own site is to recompile it with the RC0 tools, and to change the type tag to the RCO/RTW tag, and then test it.

If you want to view other people's sites, then you'll need to have Beta 2 installed.

Remember, that ALL Beta 2 sites will break  with the RTW runtime, at the very least with this type issue.

RC0 is available to download here: http://silverlight.net/getstarted/sl2rc0.aspx

Comments
Page 1 of 1 (8 items)
Leave a Comment
  • Please add 1 and 2 and type the answer here:
  • Post