Clipart Illustration of a White Character Examining With A Magnifying Glass Recently we received the following question on this blog: “Are the TFS Integration Platform tools compatible with TFS 2005? The TFS I need to migrate from is TFS 2005 while the target is TFS 2008. I was looking at the adapters in the plugins and I could not find a provider for TFS 2005. Is the 2008 provider used for TFS 2005 as well?” 

Unfortunately there were no details on the submitter and/or reply address details included in the query, so we will cover this as a separate blog post instead.

Answer: The 2008 adapters included in the plugins directory of the TFS Integration Platform tooling supports both TFS 2008 and TFS 2005 SP1.

Note: When talking to TFS 2010, we recommend that you use the TFS 2010 adapters.

Acronyms used
| TFS – Team Foundation Server |