Question

Updated build of MSI not being installed despite REINSTALLMODE=vomus property?

Troubleshooting

Start by noticing that features that should be installed are actually listed as Advertised
MSI (s) <process info>: Feature: AdminTools; Installed: Advertise; Request: Reinstall; Action: Reinstall

This is the root cause of why the files weren't updated -- the features showed up as advertised.

The next question to ask yourself is why are the features showing up as advertised?

MSI (s) <process info>: SELMGR: ComponentId '{470D6551-91D3-478E-AA51-49B6CF1772FE}' is registered to feature 'AdminTools', but is not present in the Component table. Removal of components from a feature is not supported! 
MSI (s) <process info>: SELMGR: Removal of a component from a feature is not supported 
MSI (s) <process info>: SELMGR: Component 'Configuration_Common' is registered to feature 'ClientAccess', but is not present in the FeatureComponents table. Removal of components from a feature is not supported! 
MSI (s) <process info>: SELMGR: Removal of a component from a feature is not supported

This update removed a component from a feature. Removal of components from features is not supported in small/minor updates. You can only do that in a major upgrade.

Note the reference to the EnforceUpgradeComponentRules policy.

MSI (s) <process info>: Machine policy value 'EnforceUpgradeComponentRules' is 0 

That is one way to check for this type of authoring issue -- if you set that policy to 1, MSI will fail all installs that do not follow the upgrade component rules. There's also a property you can set on the cmd line as well. Check the MSDN documentation for more details.

Content credit also belongs to

[Author: Robert Flaming]
This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at http://www.microsoft.com/info/cpyright.htm.