The XPS Essentials Pack installer (available via www.microsoft.com/xps) does not currently support Service Pack 3 (SP3) of Windows XP. 

To enable XPS support on Windows XP SP3, you can install the .Net Framework (link). An alternative workaround is to install the XPS Essentials Pack prior to upgrading to SP3.

 

We'll provide an update when a fix is available.